Curious and unwelcome AC problem, never happened before

Have had other problems over the years but this is a first. And it being June, temperatures expected to be humid and miserable soon so perfect timing.

 
 
 
 

The AC outside unit runs perfectly fine, when AC is turned on at the switch. However, the inside central fan will not. So, running box in yard, dead vents. This is bad news because if left unattended, outside box will run 24/7 and electric bill skyrockets….. not to mention any other problems it could cause.

 
 
 
 

For awhile if I clicked on the FAN ONLY, the central fan would start, and I could even flip it over to AC and get some cool air. And, if I left the AC off say all day, for a few days if I turned the AC on around say 9pm when it was cooler outside it would start the central fan and run properly all night, but back to box outside running dead central fan come around 9am. So things have been gradually “dying”.

 
 
 
 

Now, half the time when I turn the FAN ONLY on, it won’t come on either.

 
 

It appears to be some kind of switch, sensor or part that is going out although someone has mentioned possibly the A-coil icing… which I cannot find or get to, or have ever heard of.

 
 
 
 

Its a Dependable Ninety-Two. by Janitrol. New batteries in thermostat, all working fine on that end.

 
 

Has anyone ever seen this happen before?

Advertisements
Curious and unwelcome AC problem, never happened before

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s